Back
Downtime

AWS Outage: Tugboat Logic US Instance Down

Started 9 Sep at 09:23am MDT, resolved 9 Sep at 10:22am MDT.

my.tugboatlogic.com
Resolved

Services are restored.

Posted 9 Sep at 10:22am MDT.
Created

AWS is currently experiencing and outage with their parameter store, causing the Tugboat Logic app to be unavailable for all users.

Posted 9 Sep at 09:23am MDT.